So, in
the Cisco community taught the most basic basics of the interface. Those. entering the privileged mode, the configuration mode, etc. ... And then I set out to try to do something myself.
And I tried to make a small SOHO router out of the tsiska. (I am still not well versed in more complex matters, although it is a matter of time.)
I am a Linux user, so I don’t have any Packet Tracer. (More precisely, there is, but under Wine I did not try to run it.) But there is Dynamips and IOS images downloaded from torrents.ru. Among them there are images for the c7206vxr platform, which I am foolishly emulating.
')
Configuration of hosts and emulators
In the host system there is one physical interface, in LAN, in which it is inserted, there is a DHCP server. So I raised the bridge, which included the physical interface and virtual tap-interface cisco0:
br0: eth0 cisco0
Through this bridge (via the br0 interface itself, instead of eth0), the host machine now goes to LAN (and has a connection with the cisco). It turned out a virtual switch. He receives the address through DHCP.
Another bridge combined two virtual tap-interfaces:
br1: cisco1 vbox0
This bridge is not used in the host (it is raised, but no addresses have been assigned to it). It is needed only for the combination of two tap-interfaces with a virtual switch - I did not invent anything smarter.
In Dynamips, the c7206vxr-npe400 based router was emulated, and a module with two FastEthernet ports was inserted into its slot 0. At the same time, FastEthernet0 / 0 looks in LAN (tied to cisco0), FastEthernet0 / 1 - tied to cisco1.
In addition, there is another machine in VirtualBox, with Windows (it was already, it was too lazy to do one more). It has one network interface, which is tied to vbox0.
The structure of the resulting network
Thus, the following network has logically turned out:
(eth0)
|
+--(br0) -
|
(FastEthernet0/0)
c7206vxr-npe400
(FastEthernet0/1)
|
+-(0x1)
Router Configuration
(I will not write commands - it makes no sense, at the end there is a config, from which all of them are obvious)For a start, picked up FastEthernet0 / 0 with the address obtained by dhcp. FastEthernet0 / 1 has been assigned a static address. With the help of a tyke method, I configured a DHCP server on it :) after which the Windows immediately got an address from it, and now the tsiska on both interfaces was pinged.
Long could not understand how to raise nat-routing (I wanted so). Even the book about nat setup downloaded. It turned out that several different nats could be raised, of which I was interested in the overload mode.
After reading the book, nat earned. I achieved the result, with the following router configuration:
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip dhcp pool vboxes
network 192.168.2.0 255.255.255.0
default-router 192.168.2.254
dns-server 192.168.1.2
domain-name vboxes.
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
no ip http server
no ip http secure-server
!
!
access-list 1 permit any
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
!
end
If necessary, you can restrict access to nat by changing the access-list 1.
I look forward to constructive criticism from the experts!