At one warehouse, the work was organized in such a way that employees with PC skills all the time remained in the “Hazard” mode. When shipping orders, a crowd of pickers stood in line for checking and scanning barcodes. Naturally, the breakdown of one of the two operator computers turned the whole process into continuous torment for the operators themselves and joy for the rest (oh, you can drink some tea!).
In the article I will tell you how we spoiled the rest of people with the help of seamless Wi-Fi.
To unload the operators, they installed several stationary terminals, which even non-magical 1C employees can handle. But the warehouse was still regularly visited by auditors with wireless data collection terminals. Their trouble was that they had to catch a wireless network only in one warehouse corner ... yes, exactly where the people were already in abundance. In general, we decided at the same time to entangle the entire warehouse with networks of seamless Wi-Fi. This part of the project turned out to be curious.
As you know, minimalism is in fashion now. Including wired, so the equipment was looked for with PoE (Power Over Ethernet) support.
To cover the entire warehouse with a wireless network, we needed:
Access points that can work with a controlling controller and PoE-in;
Controller for controlling access points;
Decisions by Cisco, Zyxel and D-link did not fit into the budget, so Ubiquity UniFi and MikroTik remained.
The Unifi family with software controllers was well remembered from past projects with its unstable connection when customers move between points. In addition, local administrators found MikroTik RB951Ui-2HnD , who lost two ports after a lightning strike. Well, this is clearly fate, so the “invalid” was decided to be given a new life as a Wi-Fi controller.
As an access point, they originally planned for MikroTik mAP lite , which were bought with the cost and support of working with a Wi-Fi controller - Controlled Access Point system Manager (CAPsMAN) in the terminology of MikroTik. True, the inconvenient magnetic mounting on the wall was embarrassing, the counterpart of which was mounted on an unreliable adhesive tape. As a result, we bought a MikroTik mAP 2nD without any magnets, because of which the mAP lite has problems with the network when turned on .
Ordered a total of 9 points and switch D-link DES-1018MP with PoE support. This set was enough for a confident reception throughout the warehouse.
In addition to its intended use, a network tester can be made from such a point. Also included were micro-usb OTG cables, which instantly diverged across the IT department.
Let me remind you that the main problem of the warehouse was the incorrect organization of operator workplaces. Therefore, it was necessary not only to increase their number, but also to optimize the warehouse staff who were not experienced in computers. We decided to install touch-screen terminals and a barcode scanner. With the most simplified interface 1C and the absence of a standard Windows shell, it came out pretty clearly.
Thin clients, all-in-one PCs and even Raspberry Pi under Linux were considered as workstations. But with Linux, local specialists were not doing so well, so they nevertheless returned to Windows. In the end, there are fewer problems with hardware compatibility.
By the way, instead of a monoblock with a wall mount, there was an INTEL Compute Stick the size of a palm - a suitable model is released as the Lenovo IdeaCentre Stick 300 :
32 GB of disk space;
2 GB of RAM;
Windows 8.1 with Bing;
It looks like a solution to all problems. Of course, there was some distrust of the “flash drive with Windows” format itself - especially overheating the prospects for overheating and the question of speed. But the trial "flash drive" withstood all the checks without any problems, so they gave up and bought the rest.
The terminal still needed a wireless scanner, the base of which would work via USB with COM emulation - the request of the customer.
It turned out this set:
Name | Model | amount | Price, pcs |
Access point | MikroTik mAP 2nD | 9 | 2 800 ₽ |
Computer | Lenovo IdeaCentre Stick 300 | 9 | 5 900 ₽ |
Monitor | Viewsonic TD2220-2 | 9 | $ 17,000 |
Adapter | HDMI BURO DVI-D (m) - HDMI19 (f) | 9 | 590 ₽ |
SK scanner | Honeywell 1202g | 9 | 21 150 ₽ |
Switch | D-link DES-1018MP | one | 15 700 ₽ |
Total | 442 660 ₽ |
Prices are for summer 2016
It is noteworthy that the Wi-Fi network itself cost less than 50 000 ₽, even with the controller.
There is already enough material about setting up CAPsMAN on MikroTik, so I’ll tell you more about the nuances.
The network did a thing in itself, without unnecessary intersections with the office. The use of VLAN had to be abandoned, since the network equipment was already overloaded. On the Wi-Fi controller, they lifted NAT with a firewall, behind which they placed access points with clients.
In the process of testing the solution revealed several problems:
If the points and clients were in the same network segment, then when the client connected, the controller cursed the appearance of a loop and disconnected it. The problem could be circumvented by segmentation of the network or by the explicit inclusion of an access point in the bridge on the controller. I chose the first option as the most simple:
/interface bridge add name=bridge-wifi /caps-man configuration set [find comment="warehouse"] datapath.bridge=bridge-wifi # DHCP bridge-wifi
/interface wireless cap set caps-man-addresses=_ discovery-interfaces=bridge-local \ enabled=yes interfaces=wlan2
# 15. - HEX . /ip dhcp-server option add code=15 name=dns value=0x57687920616c6c207468697320736869743f # DHCP- . /ip dhcp-server network set [find comment="wi-fi client dhcp"] dhcp-option=dns
Scheme of the resulting network with two bridges
New users are not very friendly with computers, so the extra “temptations” needed to be removed. The system has a new user account with limited rights and automatic login. In addition, when loading the shell, explorer.exe was changed to the 1C startup script.
You just need to create a string parameter in the registry with the name "Shell" in the HKEY_CURRENT_USER \ Software \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon branch, and in its value set the launch path for the alternative shell. To run the VBS script, it looked like this:
cscript.exe "Path to script"
In order not to change the script for each computer, I called users in 1C in the same way as computer names.
I provide a script with comments to your judgment:
strComputer = "." strServer=" 1" strBase=" 1" Set objShell = CreateObject("Wscript.Shell") ' strUsername= objShell.ExpandEnvironmentStrings("%computername%") ' , . For iCounter = 1 to 5 If Ping(StrServer) then Exit For end If WScript.Sleep 1000 Next If iCounter =5 Then MsgBox (" , IT-") objShell.Run("shutdown -s -t 0") else ' 1 objShell.Run("""C:\Program Files\1cv8\common\1cestart.exe"" enterprise /s"+strServer+"\"+strBase+" /N"""+strUsername+"""") Set objWMIService = GetObject("winmgmts:" & "{impersonationLevel=impersonate}!\\" & strComputer & "\root\cimv2") Set colProcesses = objWMIService.ExecQuery ("Select * from Win32_Process Where Name = '1cv8.exe'") ' 1 Do While colProcesses.Count = 0 Set colProcesses = objWMIService.ExecQuery ("Select * from Win32_Process Where Name = '1cv8.exe'") WScript.Sleep 1000 Loop ' 1 Do While colProcesses.Count > 0 Set colProcesses = objWMIService.ExecQuery ("Select * from Win32_Process Where Name = '1cv8.exe'") WScript.Sleep 1000 Loop objShell.Run("shutdown -s -t 0") end if Function Ping( myHostName ) Dim colPingResults, objPingResult, strQuery strQuery = "SELECT * FROM Win32_PingStatus WHERE Address = '" & myHostName & "'" Set colPingResults = GetObject("winmgmts://./root/cimv2").ExecQuery( strQuery ) For Each objPingResult In colPingResults If Not IsObject( objPingResult ) Then Ping = False ElseIf objPingResult.StatusCode = 0 Then Ping = True Else Ping = False End If Next Set colPingResults = Nothing End Function
After some time, the terminals were added Bluetooth-speakers through which a pleasant female voice reports errors in the work with the help of Windows Speech.
The customer conducted testing of roaming as follows: an IT employee from a softphone on a mobile called me and walked through the warehouse. There were no communication breaks and "stuttering" - access points regularly passed the smartphone to each other.
Later I was told that after the introduction of the new system, the warehouse workers staged a real sabotage, with exclamations “It’s impossible to work that way!” and demonstrative work in the old fashioned way. Apparently, they realized that they would have to work instead of discussing fishing in lines and for tea. But the big boss came and adjusted everything with the magic power of persuasion.
Uh, crib, help! Vaivai Postavil, Baitik Begaet, Adinas Counting, Worker Beshelme Meshelme Nehochat
Our optimization for humans had a side effect. It turned out that such a mob in the warehouse is not needed - in the wake of the crisis in the country, this prompted the authorities to the idea of reducing staff. Now depict the stormy activities in the warehouse is not easy.
Has it ever happened to you that the use for the benefit of people turned out to be troubles for them?
Source: https://habr.com/ru/post/315984/
All Articles