I wanted to use IPv6 technology for
some reason , but my provider does not provide this service. Google suggested a
6in4 mechanism that allows IPv6 packets to be transmitted through my provider’s IPv4 network, which is supported by my
MikroTik RouterBoard 951g-2hnd router .

')
Start
First we need to:
- "White" permanent IPv4 address from the provider (the so-called dedicated IP address) - if you have a "white" but dynamic address, then you should read this: Hurricane Electric IPv6 Tunnel - IPv4 Endpoint updater
- incoming ICMP packets are not blocked (i.e., your dedicated IP address can be pinged out of the Internet. Some providers block incoming ICMP packets)
Tunnel broker
Register with a tunnel broker. I use
Hurricane ElectricGo to
this address and register. There is nothing complicated about it. In response, we receive a letter with a login and password. Enter them on the site and create a tunnel:
“User Functions - Create Regular Tunnel” In the field enter your dedicated IP address, next to your current IP address if you register where you want to configure this connection, then the dedicated IP address is identical to the current one. Next, select the nearest tunnel server, this can help us:
Looking Glass . Create!
The result is:

The IPv4 and IPv6 server addresses are listed here, as well as yours - the client. Also below is the network / 64 for your devices.
In the
“Example Configurations” tab
, select the settings for MikroTik:

Mikrotik setup
Suppose your dedicated IP address is
49.45.157.133 , the server address is
236.63.85.135 , the IPv6 server address is
2001: 470: 2e3a : 5fe :: 1 and the IPv6 client address is
2001: 470: 2e3a : 5fe :: 2/64 , and also
2001: 470 : 2e3b : 5fe :: 1/64 the first address in the dedicated / 64 subnet for you 2001: 470: 2e3b: 5fe :: / 64
Those settings that we were offered in the
"Example Configurations" section :
/interface 6to4 add comment="Hurricane Electric IPv6 Tunnel Broker" disabled=no local-address=49.45.157.133 mtu=1280 name=sit1 remote-address=236.63.85.135
/ipv6 route add disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:2e3a:5fe::1 scope=30 target-scope=10
/ipv6 address add address=2001:470:2e3a:5fe::2/64 advertise=yes disabled=no eui-64=no interface=sit1
And the IPv6 address for the BRIDGE interface:
/ipv6 address add address=2001:470:2e3b:5fe::1/64 advertise=yes disabled=no eui-64=no interface=BRIDGE
With the
BRIDGE interface, I have internal ethernet ports and a wireless interface; IPv4 is also distributed on the network.
On the computer, we enable IPv6 support if it is disabled. There should be access to the Internet via IPv6. IPv6 addresses should also appear in the interface information or in the console when the
ipconfig / all command is
issued.If everything is in order, then
ipv6.google.com should
respond , as well as successfully pass the
testIf the last part of the test did not pass and you have 9/10, then your DNS server (provided by your provider) does not have access to IPv6 Internet. It is treated easily simply register the
DNS of GoogleGoogle Public DNS IP addresses
The Google Public DNS IP addresses (IPv4) are as follows:
8.8.8.8
8.8.4.4
The Google Public DNS IPv6 addresses are as follows:
2001: 4860: 4860 :: 8888
2001: 4860: 4860 :: 8844
You can use either your primary or secondary DNS server
You can specify both numbers and primary and secondary.
IPv4 or IPv6 connections, or both.
Windows periodically generates IPv6 addresses, which is why some sites swear that the user’s IP address changes. It
simply turns off (without rebooting):
netsh interface ipv6 set global randomizeidentifiers=disabled store=active netsh interface ipv6 set global randomizeidentifiers=disabled store=persistent netsh interface ipv6 set privacy state=disabled store=active netsh interface ipv6 set privacy state=disabled store=persistent
When writing used:
IPv6 BasicsIPv6 - he is near.IPv6 protocol